Latest notes

Using CheckSUR and update packages to fix corruption

http://blogs.technet.com/b/joscon/archive/2010/05/26/using-checksur-and-update-packages-to-fix-corruption.aspx

My last post was on CheckSUR and I wanted to follow it up with how you can use the CheckSUR utility to fix corruption errors that CheckSUR might detect, but that cant be fixed with the utility.

Typically, the way that CheckSUR works is that it takes the information included with its payload, loads it locally to your machine into the \Windows\CheckSUR directory and then runs the actual executable on the system. As this executable runs, it detects discrepencies in the package store and corrects the errors that it carries a payload for. But, what do you do when you have a package manifest that shows up in the CheckSUR log but doesnt have the payload with it? If you were to call my team we’ll typically try to walk you through getting the files from another server, taking ownership of the servicing directories and moving the files. But what if this is an isolated server? Worse, what if you only have one PC at home and you’re having issues? Well, there is an easier way.

What you should do is identify the package(s) that CheckSUR was not able to fix, they’re usually listed at the end of the log. From there, you can take that information and go the Microsoft Download site and pull down the KBXXXXXX.MSU that corresponds to the package that you’re seeing failures on. Since you’ve already run CheckSUR to get to this point, you can copy that .MSU to the \Windows\CheckSUR\packages directory (NOTE: This directory does not exist by default and must be created) and then re-run CheckSUR which will take care of the rest. If you’re still having issues afterwards, that just means that something else is going on with the system that is going to require more than CheckSUR can accomplish. Typically, this is true corruption and it may be unrecoverable.

As a side note, CheckSUR doesnt have a command line interface component, so you cant rerun it once its been downloaded and installed, you just need to re-run the downloaded MSU package.

Hope that helps.

–Joseph

Completely remove Symantec Antivirus and Symantec Endpoint Protection products

http://bestnetworksinc.wordpress.com/2010/01/20/completely-remove-symantec-antivirus-and-symantec-endpoint-protection-products/

The cleanwipe utility is used to completely remove Symantec Antivirus and Symantec Endpoint Protection products.

To obtain Cleanwipe please contact Symantec Technical support.
Once the utility has been obtained please follow these instructions:

This utility can be run on Windows 2000, Windows XP (32 and 64 bit), and Windows Server 2003 (32 and 64 bit.)

Warnings:
Do not run this utility on Windows NT, Windows 9x, or Windows Me.
Do not run this utility on systems that have Symantec AntiVirus 8.x or below installed.

You cannot select individual applications to remove.

CleanWipe may remove LiveUpdate.

CleanWipe will remove Virus Definitions if you select Yes to “Do you want to do a detailed MSI Product Code registry search?…”, even when selecting No to “If Virus Defs remain after uninstalling Symantec products do you want to uninstall the Virus Defs?”. If you have other Symantec applications that use the VirusDefs folder, it is recommended that you make backup copy of the VirusDefs folder before running the CleanWipe tool. The VirusDefs folder is located under C:\Program Files\Common Files\Symantec Shared\

When using the CleanWipe utility, please be aware that it removes the following products and components from the computer:

Alert Management Server
Firewall Administrator
Quarantine Console
Quarantine Server
Symantec AntiVirus (Version 9.x and above)
Symantec AntiVirus Corporate Edition
Symantec Client
Symantec Client Firewall
Symantec Client Security
Symantec Endpoint Protection
Symantec Endpoint Protection Manager
Symantec LiveUpdate
Symantec Network Access Control
Symantec Sygate Enterprise Protection
Symantec System Center
Symevent

If you have other Symantec applications on the computer that depend on any of the applications listed above, those applications may not function properly. The customer may need to re-install the missing applications after running CleanWipe.

Note: The zip file is password protected.
Un-Zip Password: symantec

1. Extract the file to a new folder in a convenient location, such as the Desktop, using the un-zip password provided above.
2. Browse to the new folder and execute the utility by double clicking ‘CleanWipe.exe’
3. Follow the on-screen instructions.

The utility runs in verbose mode and will ask you about the components you want uninstalled.

Note: If the CleanWipe utility fails to remove Symantec Endpoint Protection, please proceed through the manual uninstall procedure for the version of the product you have installed.

You can find the manual uninstall instructions in the following document:

Title: How to manually uninstall Symantec Endpoint Protection client from Windows 2000, XP and 2003, 32-bit Editions
Solution ID: 2007073018014248
Document URL:

http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007073018014248

Title: ‘Manual uninstallation documents for Symantec Client Security products’
Solution ID: 2002031914291648
Document URL: http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2002031914291648

————————————————[UPDATE]——————————————————–
You can use CLEANWIPE from Symantec to remove the AV and all other associated applications.

To download the utility, open the following web page in a browser:

https://fileshare.symantec.com

Log in with the following information:

Login ID: cleanwipeutility
Password: CL3@nw!p3

Once you have downloaded the utility, please follow these instructions.

Note: The zip file is password protected.
Un-Zip Password: symantec

1. Extract the file to a new folder in a convenient location, such as the Desktop, using the un-zip password provided above.
2. Browse to the new folder and execute the utility by double clicking ‘CleanWipe.exe’
3. Follow the on-screen instructions.

The utility runs in verbose mode and will ask you about the components you want uninstalled.

Note: If the CleanWipe utility fails to remove Symantec Endpoint Protection, please proceed through the manual uninstall procedure for the version of the product you have installed.

You can find the manual uninstall instructions in the following document:

Title: How to manually uninstall Symantec Endpoint Protection client from Windows 2000, XP and 2003, 32-bit Editions
Solution ID: 2007073018014248
Document URL:

http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007073018014248

Title: ‘Manual uninstallation documents for Symantec Client Security products’
Solution ID: 2002031914291648
Document URL: http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2002031914291648

Error while importing option “6.” while moving DHCP database from Windows Server 2008 to another Windows Server 2008/2003 or 2008 R2

http://mykbit.blogspot.com/2010/03/error-while-importing-option-6-while.html

To move DHCP from one server (2003/2008) to another you can use the following steps

  1. At the command prompt type netsh dhcp server export C:\dhcpdata.txt all , and then press ENTER.

Note: You must have local administrator permissions to export/import the data.

Configure the DHCP server service on the server that is running Windows Server 2008

  1. Add DHCP Server Role
  2. Make sure to Authorize DHCP while installing the Role.

Import the DHCP database

  1. Copy the exported DHCP database file to the local hard disk of the Windows Server 2008-based computer.
  2. At the command prompt, type netsh dhcp server import c:\dhcpdata.txt all and press ENTER

If might receive the following error

“Error while importing option “6.” “This option conflicts with the existing option “” An Internal Error Occurred.”

It is because by default when you install DHCP Server Role, it puts the following entries in Server Options.

006 DNS Server
015 DNS Domain Name

To fix the Error –> Just delete the above two entries from Server options and Run the Import DHCP database command again

Steps to move a DHCP database from a Windows Server 2003 or 2008 to another Windows Server 2008 machine

http://blogs.technet.com/b/networking/archive/2008/06/27/steps-to-move-a-dhcp-database-from-a-windows-server-2003-or-2008-to-another-windows-server-2008-machine.aspx?PageIndex=1#comments

 

The DHCP database can be moved or migrated from a Windows Server 2003 server to a Windows Server 2008 server, or from one Windows Server 2008 server to another. The information below details the necessary steps.

Export the DHCP database from a server that is running Microsoft Windows Server 2003 or Windows Server 2008

To move a DHCP database and configuration from a server that is running Windows Server 2003 or Windows Server 2008 to another server that is running Windows Server 2008:

1. Log on to the source DHCP server by using an account that is a member of the local Administrators group.

2. Click Start, click Run, type cmd in the Open box, and then click OK.

3. Type netsh dhcp server export C:\dhcp.txt all , and then press ENTER.

Note: You must have local administrator permissions to export the data.

Configure the DHCP server service on the server that is running Windows Server 2008

1. Click Start, click Administrative Tools, click Server Manager. If needed acknowledge User Account Control.

2. In Roles Summary click Add Roles, click Next, check DHCP server, and then click Next.

Import the DHCP database

1. Log on as a user who is an explicit member of the local Administrators group. A user account in a group that is a member of the local Administrators group will not work. If a local Administrators account does not exist for the domain controller, restart the computer in Directory Services Restore Mode, and use the administrator account to import the database as described later in this section.

2. Copy the exported DHCP database file to the local hard disk of the Windows Server 2008-based computer.

3. Verify that the DHCP service is started on the Windows Server 2008-based computer.

4. Click Start, click Run, type cmd in the Open box, and then click OK.

5. At the command prompt, type netsh dhcp server import c:\dhcpdatabase.txt all , and then press ENTER, where c:\dhcpdatabase.txt is the full path and file name of the database file that you copied to the server.

Note When you try to export a DHCP database from a Windows 2000/2003 domain controller to a Windows Server 2008 member server of the domain, you may receive the following error message:

Error initializing and reading the service configuration – Access Denied

Note You must have local administrator permissions to import the data.

6. To resolve this issue, add the Windows Server 2008 DHCP server computer to the DHCP Admins group at the Enterprise level and redo steps 4 & 5.

7. If the "access is denied" error message occurs after you add the Windows Server 2008 DCHP server computer to the DHCP Admins group at the Enterprise level that is mentioned in step 6, verify that the user account that is currently used to import belongs to the local Administrators group. If the account does not belong to this group, add the account to that group, or log on as a local administrator to complete the import and redo steps 4 & 5.

Authorize the DHCP server

1. Click Start, point to All Programs, point to Administrative Tools, and then click DHCP.

Note You must be logged on to the server by using an account that is a member of the Administrators group. In an Active Directory domain, you must be logged on to the server by using an account that is a member of the Enterprise Administrators group.

2. In the console tree of the DHCP snap-in, expand the new DHCP server. If there is a red arrow in the lower-right corner of the server object, the server has not yet been authorized.

3. Right-click the server object, and then click Authorize.

4. After several moments, right-click the server again, and then click Refresh. A green arrow indicates that the DHCP server is authorized.

– Wayne Melvin

How do I increase the message size limits?

 

https://migrationwiz.zendesk.com/entries/490005-how-do-i-increase-the-message-size-limits

To display current message size limits:

  1. Open the Exchange Management Shell
  2. Enter the following command:

Get-TransportConfig | Format-List -Property MaxReceiveSize, MaxSendSize

Get-SendConnector | Format-List -Property Identity, MaxMessageSize

Get-ReceiveConnector | Format-List -Property Identity, MaxMessageSize

To increase size limits on your Exchange Server 2010 machine:

  1. Open the Exchange Management Shell
  2. Enter the following commands:

Set-TransportConfig -MaxReceiveSize 100MB -MaxSendSize 100MB

Get-SendConnector | Set-SendConnector -MaxMessageSize 100MB

Get-ReceiveConnector | Set-ReceiveConnector -MaxMessageSize 100MB

Windows Server 2008 and Windows Server 2008 R2 DNS Servers may fail to resolve queries for some top-level domains

http://support.microsoft.com/default.aspx?scid=kb;EN-US;968372

To resolve the issue and continue using root hints, change the MaxCacheTTL registry value to 2 days or greater.
Warning: Serious problems might occur if you modify the registry incorrectly by using Registry Editor or another method. These problems might require you to reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
1. Start Registry Editor (regedit.exe).
2. Locate the following registry key:
3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters
4. On the Edit menu, click New, click DWORD (32-bit) Value, and then add the following value:

  • Value: MaxCacheTTL
  • Data Type: DWORD
  • Data value: 0x2A300 (172800 seconds in decimal, or 2 days)

5. Click OK.
6. Quit Registry Editor.
7. Restart the DNS Server service.